Also, when it comes to flags, I use the isSomething naming convention regardless of private/public status. If it's a private flag with a public getter, I make the public getter the name of the flag without the is.

private var isActive:Boolean;

public function get active():Boolean
{
    return isActive;
}

Steven Sacks wrote:
I only use underscore for private variables if I have a public getter and/or setter for that private variable. Otherwise, I don't use underscore. It's also a easy way to see, at a glance, which private variables are private and which are public but private.

private var _title:String;

public function get title():String
{
    return _title;
}
_______________________________________________
Flashcoders@chattyfig.figleaf.com
To change your subscription options or search the archive:
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders

Brought to you by Fig Leaf Software
Premier Authorized Adobe Consulting and Training
http://www.figleaf.com
http://training.figleaf.com
_______________________________________________
Flashcoders@chattyfig.figleaf.com
To change your subscription options or search the archive:
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders

Brought to you by Fig Leaf Software
Premier Authorized Adobe Consulting and Training
http://www.figleaf.com
http://training.figleaf.com

Reply via email to