Hmm, actually, it's kinda funny. I was originally only confirming your 
observation that ailerons, flaps and spoilers were animating correcty on a 
different system. But your question triggered my curiosity, and I decided to 
explore the 3ds file a litte bit. I found that the objects named Elevator01H 
through Elevator06H didn't exist in the 3ds file I downloaded. So I changed 
the object name in the md11.xml file to remove the trailing 'H' and now 
elevator animation also works on my side. :-) So, you might want to check the 
names of the elevator objects in your model file. Remember, since I don't 
have 3d studio on my computer, the only way to examine these files is by 
dumping them to a console and make use to the standard unix tools (grep, cat, 
less) to make sense out of them. :-)

Well, I hope this gives you a hint at the problem. 

B.t.w. by "trimming", do you refer to the JSBSim ground trimming procedure? 
That's fixed on my system now, and should traverse its way into flightgear 
soon. 

Cheers,
Durk

<animation>
 <type>rotate</type>
 <object-name>Elevator01</object-name>
 <object-name>Elevator02</object-name>
 <property>surface-positions/elevator-pos-norm</property>
 <factor>18</factor>
 <center>
  <x-m>57.70729</x-m>
  <y-m>-8.77777</y-m>
  <z-m>1.96712</z-m>
 </center>
 <axis>
  <x>-2.24377</x>
  <y>4.65299</y>
  <z>-0.63319</z>
 </axis>
</animation>

<animation>
 <type>rotate</type>
 <object-name>Elevator05</object-name>
 <object-name>Elevator06</object-name>
 <property>surface-positions/elevator-pos-norm</property>
 <factor>18</factor>
 <center>
  <x-m>55.46352</x-m>
  <y-m>4.12478</y-m>
  <z-m>1.33393</z-m>
 </center>
 <axis>
  <x>2.24377</x>
  <y>4.65299</y>
  <z>0.63319</z>
 </axis>
</animation>



On Monday 24 May 2004 21:58, Ampere K. Hardraade wrote:
> Do the elevators and the trim works for you?
>
> Regards,
> Ampere
>
> On May 24, 2004 02:34 pm, Durk Talsma wrote:
> > Okay, these animations all work nicely now.
> >
> > > The attachment contains what I have done so far.  Control surfaces that
> > > are working are the ailerons, flaps and spoilers.  Control surfaces
> > > that aren't working are the elevators and I can use some help with
> > > them.  I have put off doing the rudders until the textures are done.
> >
> > _______________________________________________
> > Flightgear-devel mailing list
> > [EMAIL PROTECTED]
> > http://mail.flightgear.org/mailman/listinfo/flightgear-devel
>
> _______________________________________________
> Flightgear-devel mailing list
> [EMAIL PROTECTED]
> http://mail.flightgear.org/mailman/listinfo/flightgear-devel


_______________________________________________
Flightgear-devel mailing list
[EMAIL PROTECTED]
http://mail.flightgear.org/mailman/listinfo/flightgear-devel

Reply via email to