Bohnert Paul wrote:

This is my first attempt at making FlightGear.

My OS is Fedora Core 2. I have FlighGear-0.9.5 source.
I have glut-3.7-12.lvn.1.1.i386rpm installed.

When I run configure it reports;

checking GL/glut.h usability... no
checking GL/glut.h presence... no
checking for GL/glut.h... no
checking GLUT/glut.h usability... no
checking GLUT/glut.h presence... no
checking for GLUT/glut.h... no
Neither GL/glut.h nor GLUT/glut.h found.  Cannot
continue

What version of glut do I need? Where do I look in
the source to tell what glut I need? Or, where am I
going wrong?



You need both the glut and glut-dev rpm's installed. The latter gives you the required header files for compilling. Also, consider removing glut and installing the freeglut packages that come with Fedora, those will probably work out better for you in the long run.


Also, you will need to grab openal (www.openal.org) from cvs and build/compile that. Unfortunately they don't have versioned releases so the best you can do is just grab their current cvs.

I had a lot of trouble trying to get plib-cvs to build on Fedora Core 2 due to strange automake problems, but plib-1.8.3 from plib.sf.net worked perfectly.

Regards,

Curt.

--
Curtis Olson http://www.flightgear.org/~curt HumanFIRST Program http://www.humanfirst.umn.edu/
FlightGear Project http://www.flightgear.org
Unique text: 2f585eeea02e2c79d7b1d8c4963bae2d



_______________________________________________ Flightgear-devel mailing list [EMAIL PROTECTED] http://mail.flightgear.org/mailman/listinfo/flightgear-devel 2f585eeea02e2c79d7b1d8c4963bae2d

Reply via email to