Erik Hofman writes:

> David Luff wrote:
> 
> > Hi Erik,
> > 
> > You need either 2.4.x (the latest stable version) or 2.5.x (2.5.2 definately 
> > works), the latest unstable version.  2.2.x doesn't work unfortunately, I think I 
> > use parts of the api that weren't present then.  Since 2.3.3 is an out-of-date 
> > unstable version (wxWindows uses the Linux kernal numbering convention) I wouldn't 
> > recommend it.  I've never had any problem compiling wxGTK-2.4.x on Linux with 
> > either 2.95 or 3.3.
> > 
> > It you can't sort it out then I'll see if I can get it to work on earlier 
> > versions.  I've compiled it (TaxiDraw) on Linux with both g++-2.95 and g++-3.3 by 
> > the way.
> 
> Never mind , I gave up on WxWindows.
> If it ain't GTK I won't use it.
> 

As far as I know, wxGTK uses native GTK behind the scenes on Linux / Unix.  According 
to

http://www.wxwindows.org/platform.htm

versions 2.2 and 2.5 have been compiled on IRIX 6.5 with the MIPSPro 7.3 compiler.  
I'm somewhat dissapointed that you're having such problems - I was hoping it would be 
a genuinely cross platform toolkit in practice as well as theory.

Cheers - Dave

_______________________________________________
Flightgear-devel mailing list
[EMAIL PROTECTED]
http://mail.flightgear.org/mailman/listinfo/flightgear-devel
2f585eeea02e2c79d7b1d8c4963bae2d

Reply via email to