Vivan,
I followed your advice and started over and FightGear WORKS!!!.
I had to place AL and GL in the /cygwin/include instead of
/usr/local/include. If I dont do that when I run ./configure for SimGear,
it errors out at the end and says openAL has to be installed. The last few
lines before this error message look for openAl files and three no's
appear.

Thanks for your help. I am still getting the Segmentation fault <core
dumped> when I exit FlightGear but it runs regardless. That might have not
been my problem running fgfs the whole time.

I am going to move on to modifiying the HUD. Wish me luck..

_Yenew




> -----Original Message-----
> From: [EMAIL PROTECTED] [mailto:flightgear-devel-
> [EMAIL PROTECTED] On Behalf Of YENEW T KASSAYE
> Sent: 19 May 2005 23:04
> To: FlightGear developers discussions
> Subject: RE: [Flightgear-devel] FlightGear0.9.8 Segmentationfault
> <coredumped>Please Help!
>
> Thanks Vivan,
>
> I made the corrections. No change. I do want to mention that when I am
> compiling simgear,it gives me errors about openAL not being loaded. I
> defeated this problem by placing AL and GL in /cygwin/include instead of
> /usr/local/include. Would this create a problem?

I think you ought to get it all to compile in the advised locations. A
possible cause of problems is multiple versions of AL and GL. Make sure
that
you only have one version of each. What are your errors in compiling
SimGear
with OpenAl in the 'correct' location?

A possible way forward is to start over - uninstall Cygwin, and start from
there. Download and install compatible versions of plib, OpenAl (our
variant) etc, and rebuild. Tedious, but probably quicker than chasing down
files in obscure directories.

> I also uninstalled the  X11 package from cygwin.

Hmm ... this was a problem in the past, but I think it shouldn't be needed
now

> This allowed simgear to
> compile. But I still have the seg. dump after I compile and run fgfs from
> cygwin. Still stuck! It brings up the intro screen and never puts you in
> the cockpit.
>
> I do have the already compiled executable downloaded from flightgear.org
> and it works fine on this machine. I ran fgrun from cygwin and it works.
> But I need to be able to compile because I am modifying the hud to feed
in
> SEP data.
>
>

Keep trying, it definitely does work.

V.



_______________________________________________
Flightgear-devel mailing list
Flightgear-devel@flightgear.org
http://mail.flightgear.org/mailman/listinfo/flightgear-devel
2f585eeea02e2c79d7b1d8c4963bae2d


_______________________________________________
Flightgear-devel mailing list
Flightgear-devel@flightgear.org
http://mail.flightgear.org/mailman/listinfo/flightgear-devel
2f585eeea02e2c79d7b1d8c4963bae2d

Reply via email to