I'm still using Red Hat 8.0 on kernel 2.4.24 with 3 joysticks from CH products on a Sweex usb 2.0 hub.

/usr/src/make xconfig
support for usb (usbcore.o) -- Y
Preliminary USB device filesystem -- Y
EHCI HCD -- Y
UHCI alternate driver (JE) -- Y
USB full HID support -- Y
HID Input layer support -- Y
Input core support -- Y
Joystick support -- Y

lsmod:
Module Size Used by
rtnet 53768 0
rtai_rtdm 12900 0 [rtnet]
rtai_shm 7368 0 (unused)
rtai_fifos 17672 0 (unused)
rtai_sched_up 48241 0 [rtnet rtai_rtdm]
rtai 39616 2 [rtnet rtai_rtdm rtai_shm rtai_fifos rtai_sched_up]
3c59x 29552 1
mousedev 5492 1

dmesg | grep usb:
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb.c: new USB bus registered, assigned bus number 1
usb.c: new USB bus registered, assigned bus number 2
usb.c: new USB bus registered, assigned bus number 3
usb.c: new USB bus registered, assigned bus number 4
usb.c: new USB bus registered, assigned bus number 5
usb.c: registered new driver hid
input: USB HID v1.00 Joystick [CH PRODUCTS CH PRO PEDALS USB ] on usb1:3.0
input: USB HID v1.00 Joystick [CH PRODUCTS CH THROTTLE QUADRANT] on usb1:4.0
input: USB HID v1.00 Joystick [CH PRODUCTS CH FLIGHT SIM YOKE USB ] on usb1:5.0

So far so good, I would say ...BUT ...this is the output of js_demo:

Joystick test program.
~~~~~~~~~~~~~~~~~~~~~~
Joystick 0 not detected
Joystick 1 not detected
Joystick 2 not detected
Joystick 3 not detected
Joystick 4 not detected
Joystick 5 not detected
Joystick 6 not detected
Joystick 7 not detected

I've tried every possible combination of modules concerning usb and joysticks but I can't get any of the USB joysticks to work. Can someone tell me why these joysticks don't work while they are installed correctly.



_______________________________________________
Flightgear-devel mailing list
Flightgear-devel@flightgear.org
http://mail.flightgear.org/mailman/listinfo/flightgear-devel
2f585eeea02e2c79d7b1d8c4963bae2d

Reply via email to