DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18371>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18371

Included SVG images: PDF rendering with batch OK, with API not.

           Summary: Included SVG images: PDF rendering with batch OK, with
                    API not.
           Product: Fop
           Version: 0.20.5
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: svg
        AssignedTo: [EMAIL PROTECTED]
        ReportedBy: [EMAIL PROTECTED]


I have a XSL file with the following block to include a SVG grafic:

----
<fo:block>
<fo:instream-foreign-object>
<svg:svg width="600" height="400" xmlns:xlink="http://www.w3.org/2000/svg";>
<svg:image width="800" height="400" xlink:href="TestSVG.svg"/>
</svg:svg>
</fo:instream-foreign-object>
</fo:block>
----

the complete document renders correctly to PDF if i use FOP from the command 
line. if rendered through the Java API, the resulting PDF shows a "broken" 
image placeholder instead of the included SVG graphics. The svg 
file "TestSVG.svg" is in the directory, so the test in the very same directory 
with the same files with fop.bat works.

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

Reply via email to