--- Jeremias Maerki <[EMAIL PROTECTED]> wrote:
> Glen,
> over all, your proposed changes are ok (the two
> earlier posts, but see
> comment for this one further down). But first, I
> want to make sure you
> remember that branch plan [1] I published earlier.
> It says that until
> 2005-04-20 the branch is somewhat experimental and
> might yet fail. You
> seem to have big confidence that it'll work out.
> After my findings
> during the last two weeks I must say that I'm not
> 100% confident anymore
> even though I can now see the light at the other end
> of the tunnel.
> Table layout is very critical here. So if I were you
> I'd wait a little
> until I did that.

Will do.

> The layout dimension mechanism is used for resolving
> percentage based
> property values. Remember [2]? This mechanism
> shouldn't simply be
> removed but replaced by something like I outlined in
> that post. 

I can look at this--I think you want BPD() and IPD()
to be better set, so we can reduce our dependence on
the layout dimension mechanism.  Also, in the interim
we can also look at setting the correct values with
this mechanism as you also mentioned.

[BTW, we have flowBPD and flowIPD instance variables
in PSLM that I would love to get rid of in favor of
reading the precise .getIPD() and .getBPD() value from
the Area object in question.  Obtaining directly from
the Area object would create much more readable and
less error-prone code.  Problem is, right now, AFAICT
the meaning of flowBPD and flowIPD keeps changing in
PSLM--I'm not sure which Area object it is referring
to--span/BodyRegion/NormalFlow, etc., etc.  If anyone
can shed light on this, it would be most appreciated.]


> [2]

Reply via email to