> -----Original Message-----
> From: Glen Mazza [mailto:[EMAIL PROTECTED]
>
> --- [EMAIL PROTECTED] wrote:
> >
> >   -    protected void startPart(BlockSequence list)
> > {
> >   +    protected void startPart(BlockSequence list,
> > int localPageNumber) {
>
> "boolean isFirstPageByBlock" is probably better.
>
> The meaning of "localPageNumber" to indicate the first
> page created by a particular block I think will cause
> confusion, especially when read within PSLM.  Also,
> since the logic only cares about whether or not the
> page is the *first* page being rendered by the block,
> a boolean would appear to better capture the usage of
> this variable.

I agree with this reasoning, and can't seem to come up with situations where
the actual page-count for a given BlockSequence *would* be needed... (could
be that I'm overlooking something)

Along these same lines, the modifications to the code in PSLM would yield
the more compact:

...
} else {
    // (comment on the following line of code)
    handleBreak(isFirstByBlock ? list.getStartOn() : Constants.EN_PAGE);
}
...


Cheers,

Andreas

Reply via email to