+1 to all three points. But I'll never define a variable called
blockProgressionDimension! That's always going to be bpd for me, but
then ipd and bpd are so omnipresent so it shouldn't be a problem.
Exceptions prove the rule, don't they? :-)

On 09.09.2005 01:55:06 J.Pietschmann wrote:
> Hi devs,
> while examining the Checkstyle and JavaDoc complaints I
> got a few more questions about the FOP style:
> 1. There is still quite a bit of hungarian notation here and
>   there. Hungarian notation generally sucks unless it is
>   consistently applied. Furthermore, it is systems hungarian
>   (see http://www.joelonsoftware.com/articles/Wrong.html),
>   which unconditionally sucks.
>   And yes, we do already have an "int bFooFlag".
>   I'd like to exterminate this.
> 2. There are two different styles for constructors and setters
>   in use:
>     Constructor(int foo) {
>       this.foo=foo
>     }
>   and
>     Constructor(int f) {
>       foo=f
>     }
>   We should standardize on one form. I'd like the first because
>   the second may have the undesirable effect of using unintuitive
>   abbreviations or alternative names for the parameter.
>   I told Checkstyle laready to accept the first form (there are
>   *lots* of warnings about it). Unfortunately, Checkstyle can't yet
>   enforce it.
> 3. We have too much weird abbreviations everywhere. In particular,
>   usage of abbreviations is wildly inconsistent. I'd like to
>   remind everyone that using proper words to compose identifiers
>   has advantages. With the autocompletion features of modern IDEs,
>   long identifiers shouldn't impair typing too much.
>   I'll probably expand randomly choosen names in the future, which
>   may include class names. Tell me now if you don't like this.
> 
> Regards
> J.Pietschmann



Jeremias Maerki

Reply via email to