I'm glad you volunteer to do any changes. But there's also something
else. We had a vote in March about merging back the "API Finalization"
branch back into Trunk. You voted +1 back then knowing the the branch
had the word "Finalization" in it. Furthermore, we've already
communicated with 0.92beta that "the API is now considered stable" [1].
So, if the committership feels we should take another round of API
improvements, I won't block (your suggestions are all reasonable) but I
won't take the lead here. Either you or someone else has to take the
lead and push for it (consensus gathering, changes, documentation,

I'm leaving tomorrow for Ireland and will be away for another week after
ApacheCon on "green holidays" (Swiss style), so I wouldn't have time
anyway. But I'll try to keep an eye on the lists as often as possible.


On 20.06.2006 23:24:15 J.Pietschmann wrote:
> Jeremias Maerki wrote:
> > Ok, if we want that 1.0 won't be out before September.
> Too bad. As already mentioned, changing IPD page masters worked
> reasonably well in 0.20.5 and I think people will expect this to
> work in a 1.0 release too.
> OTOH, if the frequency of questions on the lists are taken into
> account, support for collapsing table borders, even if only partial,
> has a much higher priority. I don't see any of the other mentioned
> features as a show stopper for 1.0.
> > That remark comes pretty late, but yeah, if anyone else think this
> > should be fixed, we should do it SOON.
> Well, someone should have looked at this before (I made some style
> related notes during the API discussion).
> The guide lines are
> - consistency with the Java RTL identifier guide lines, in particular
>   the rule that common acronyms in identifiers are all upper case
> - internal consistency
> - avoiding redundancy
> We can restrict this to the essential user visible API, i.e.
> the packages o.a.fop.apps and o.a.fop.cli.
> My suggestions
> - Rename o.a.fop.apps to o.a.fop.api. This is a major change breaking
>    everything, and should have been done in the same step when the
>    Driver was replaced by the Fop class. I wont insist on this change.
> - If the "Fop" in FopFactory is the acronym for "FO processor", the
>    class should be named FOPFactory instead. Same for Fop --> FOP
>    (precedent is the class).
> - If it's the other way around FOPException should be renamed as
>    FopException.
> - MimeConstants should be renamed as MIMEConstants.
> - FOURIResolver should probably be renamed as plain URIResolver (the FO
>    prefix may be deemed redundant because of the package), or as
>    FOPURIResolver. Two consecutive acronyms in an identifier are awkward
>    in any case.
> - Same for FOUserAgent --> UserAgent or FOPUserAgent
> - The method applyHttpBasicAuthentication should be renamed
>    applyHTTPBasicAuthentication.
> - Rename the CLI parameter "-param" to "-xsltparam" or something (too
>    generic)
> We could keep and deprecate the unrenamed classes in order to ease the
> transition. If the API is really declared "stable", the beta tag can
> be dropped from the release number even for a pre 1.0 release.
> Should we hold a formal vote on the API style issue? Either way, I'd
> even volunteer to do the changes (it's easy enough :-).
> J.Pietschmann

Jeremias Maerki

Reply via email to