DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG· RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT <http://issues.apache.org/bugzilla/show_bug.cgi?id=40271>. ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND· INSERTED IN THE BUG DATABASE.
http://issues.apache.org/bugzilla/show_bug.cgi?id=40271 ------- Additional Comments From [EMAIL PROTECTED] 2006-08-26 19:22 ------- Patrick, A few requests and pointers: * Can you try and give the variables a bit more descriptive names? It's just that at times, I was getting a bit lost in the 'iX's... :) * Don't be afraid/ashamed to re-use existing structures: I get the impression that your MinMax datatype is only slightly different from the MinOptMax we already heavily use. Maybe you could use the latter...? * I'd also put the stuff related to table-layout in separate methods (instead of inserting the new code- blocks into existing methods), and make sure the extra objects don't get created for fixed layout. For fixed layout, it is unnecessary to have two TableContentLMs and two ColumnSetups... Also, as an alternative to the implementation of getMinMaxTextWidths() --still using the misleading name?-- I'm beginning to wonder whether the computation of min and max content widths is functionality that belongs in the ElementListUtils utility class. Its operand is always an element list. For the rest, it seems logical, but note that we still can do little more than judge the patch by looking at it, since it is still incomplete... It would be cool if you could provide us with an integrated patch containing all changes (including added files: this time the MinMax class is missing, but see above, maybe MinOptMax can be used?), so we can see it in action for ourselves. Thanks, Andreas -- Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are the assignee for the bug, or are watching the assignee.