DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUGĀ·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41133>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED ANDĀ·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41133

           Summary: SVG image colors are partially wrong
           Product: Fop
           Version: 0.20.5
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: pdf
        AssignedTo: fop-dev@xmlgraphics.apache.org
        ReportedBy: [EMAIL PROTECTED]


The SVG image in the xsl-fo document below, contains the color rgb(243,220,241)

If FOP (with option myDriver.setRenderer(Driver.RENDER_PDF);) converts this 
xsl-fo document to a .pdf file, the the color in the .pdf file will be 
set/displayed: rgb(255,220,241).

The same occurs if we transform the xsl-fo document to pdf using XML Spy.

It seems so, that FOP set the color values 243 and higher to 255.

If we run FOP and render a SVG, then the color is ok. 
If we import the SVG image to Open Office and save it as a .pdf file, then the 
color is correct too.

SVG image in xsl-fo document:
=============================
<fo:block space-before="1.838452mm" space-after="0.0mm" margin-left="0.0mm" 
white-space-collapse="false" text-align="center" hyphenate="false">
                                <fo:instream-foreign-object>
                                        <svg 
xmlns="http://www.w3.org/2000/svg"; xmlns:xlink="http://www.w3.org/1999/xlink"; 
style="stroke-dasharray:none; shape-rendering:auto; font-family:'sansserif'; 
text-rendering:auto; fill-opacity:1; color-interpolation:auto; color-
rendering:auto; font-size:12; fill:black; stroke:black; image-rendering:auto; 
stroke-miterlimit:10; stroke-linecap:square; stroke-linejoin:miter; font-
style:normal; stroke-width:1; stroke-dashoffset:0; font-weight:normal; stroke-
opacity:1;" width="60mm" preserveAspectRatio="xMinYMin" viewBox="0 0 230 111" 
height="29mm">
                                                <defs id="genericDefs"/>
                                                <g transform="translate(0,0)">
                                                        <g style="fill:rgb
(243,220,241); stroke:rgb(243,220,241);">
                                                                <rect x="98" 
y="74" width="112" style="stroke:none;" height="26"/>
                                                        </g>
                                                </g>
                                        </svg>
                                </fo:instream-foreign-object>
                        </fo:block>

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

Reply via email to