Paul,

due to changes in the ImageLoader API you have to use matching version
of JEuclid for FOP to work.

I tried to reproduce your error and I was unable to reproduce it using
FOP trunk and JEuclid 3.1.3.

Also, in the .fo given:
http://www.nabble.com/file/p20339979/doc.xml.fo

There is no MathML used.

If this is the file you're having trouble with:
- delete (temporary) the jeuclid libs and see if that helps. If so, I
need to fix this in JEuclid [ I'll then ask for more information ].
- if that did not change anything it's a bug in fop. In this case,
please make the PNG files available, maybe there error lies therein?


Max



Nobble schrieb:
> I have now tried with the combination: apache fop 0.95 and jEuclid 3.0.3. I
> get this error:
> 
> Making portrait pages on A4 paper (210mmx297mm)
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/fop/image/analyser/XMLReader$Converter
>         at java.lang.Class.forName0(Native Method)
>         at java.lang.Class.forName(Class.java:169)
>         at
> org.apache.fop.fo.ElementMappingRegistry.addElementMapping(ElementMappingRegistry.java:94)
>         at
> org.apache.fop.fo.ElementMappingRegistry.setupDefaultMappings(ElementMappingRegistry.java:77)
>         at
> org.apache.fop.fo.ElementMappingRegistry.<init>(ElementMappingRegistry.java:64)
>         at org.apache.fop.apps.FopFactory.<init>(FopFactory.java:151)
>         at org.apache.fop.apps.FopFactory.newInstance(FopFactory.java:166)
>         at
> org.apache.fop.cli.CommandLineOptions.<init>(CommandLineOptions.java:102)
>         at org.apache.fop.cli.Main.startFOP(Main.java:153)
>         at org.apache.fop.cli.Main.main(Main.java:197)
> 
> Paul
> 
> 
> Adrian Cumiskey wrote:
>> Also it may be helpful if you are able to tell us which version of JEuclid
>> you are using.
>>
>> Adrian.
>>


Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to