Hi Vincent, > Speaking of that, there’s a rule that I would suggest to disable: the > HiddenFieldCheck. I don’t really see its benefit. It forces to find > somewhat artificial names for variables, where the field name is exactly > what I want. Sometimes a method doesn’t have a name following the > setField pattern, yet still acts as a setter for Field. This rule would > make sense if we were using a Hungarian-like notation for variables > (mMember, pParam, etc.), but that’s not the case in FOP. > > WDYT?
Yes I would vote for it. In modern IDE's one sees clearly the difference between an instance field and a local variable. This is also the reason why this Hungarian-like scope notation is largely gone in Java. Best Regards Alex
Description: This is a digitally signed message part