On 06 Feb 2011, at 14:40, adelme...@apache.org wrote:

> Author: adelmelle
> Date: Sun Feb  6 13:40:31 2011
> New Revision: 1067665
> URL: http://svn.apache.org/viewvc?rev=1067665&view=rev
> Log:
> Code cleanup:
> - reduce code duplication in getNextKnuthElements()
> - removed references to experimental BlockStackingLM.bpUnit
> - changed silly private method label

What a joke! Taking the time to extract some 30 lines of code into a separate 
method. Not even bothering to come up with an appropriate name 
(refactoredBecauseOfDuplicateCode() --duh!) or to think about whether something 
similar could be done about the other 50 lines of duplicate --errm, sorry, that 
was 'triplicated'-- code... :-|

Now, there's still some duplication left, but I did not immediately see a way 
out of that. Perhaps a fresh look at the trimmed forest will do wonders here. 
We'll see...



Reply via email to