Bug #: 51327
           Summary: fop.bat, fop.cmd, ... should have svn:executable
                    property in SVN ?
           Product: Fop
           Version: 1.0
          Platform: PC
            Status: NEW
          Severity: minor
          Priority: P2
         Component: general
    Classification: Unclassified

After installing fop-1.0 (to upgrade from fop-0.95) and then running Visual C
nmake which then invokes fop.bat, I got the following message:

   c:\...\fop-1.0\fop.bat ... ...
NMAKE : fatal error U1045: spawn failed : No error

Windows 7; MSVC 9 (2008); 
fop-1.0 installed from using:
UnZip 6.00 of 20 April 2009, by Cygwin. Original by Info-ZIP.

A bit of poking around on the web suggested a permissions problem.

I don't really understand how to use Windows7 tools to view/change file
permissions so I just used cygwin 'ls' and found that fop.bat wasn't marked as
executable (according to cygwin 'ls').

So: I tried a different unzip (Winzip) to install fop-1.0 again (after removing
the first install) and found that that fop.bat was then magically marked as
executable; invoking fop.bat via nmake worked AOK.

I don't understand all that goes on behind the scenes but I'm guessing that
setting the svn:executable property for the Windows .bat & .cmd files in the
SVN repository might be the right way to go.

Contents of /xmlgraphics/fop/trunk/fop.bat

Revision 697152 - (show annotations) (download)
Fri Sep 19 17:01:03 2008 UTC (2 years, 8 months ago) by adelmelle
File MIME type: text/plain
File size: 3915 byte(s) 


Name     Value
svn:eol-style     CRLF
svn:keywords     Author Date Id Revision

Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.

Reply via email to