https://issues.apache.org/bugzilla/show_bug.cgi?id=54089

          Priority: P2
            Bug ID: 54089
          Assignee: fop-dev@xmlgraphics.apache.org
           Summary: maven dependency has wrong avalon group id
          Severity: major
    Classification: Unclassified
          Reporter: ll...@astute.biz
          Hardware: PC
            Status: NEW
           Version: 1.1
         Component: general
           Product: Fop

The maven pom for fop 1.1 uses incorrect dependency for avalon framework. With
4.2.0 the the group id changed to avalon-framework from
org.apache.avalon.framework

workaround: update pom as follows

 <dependency>
  <groupId>org.apache.xmlgraphics</groupId>
  <artifactId>fop</artifactId>
  <version>1.1</version>
  <exclusions>
      <exclusion>
          <artifactId>avalon-framework-api</artifactId>
          <groupId>org.apache.avalon.framework</groupId>
      </exclusion>
      <exclusion>
          <artifactId>avalon-framework-impl</artifactId>
          <groupId>org.apache.avalon.framework</groupId>
      </exclusion>
  </exclusions>
  </dependency>
  <!--  these two are to correct issues in  fop dependency --> 
  <dependency>
   <groupId>avalon-framework</groupId>
   <artifactId>avalon-framework-api</artifactId>
   <version>4.2.0</version>
  </dependency>
  <dependency>
   <groupId>avalon-framework</groupId>
   <artifactId>avalon-framework-impl</artifactId>
   <version>4.2.0</version>
  </dependency>

-- 
You are receiving this mail because:
You are the assignee for the bug.

Reply via email to