[ 
https://issues.apache.org/jira/browse/FOP-2485?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14601233#comment-14601233
 ] 

Luis Bernardo commented on FOP-2485:
------------------------------------

It seems xalan 2.7.2 needs xercesImpl 2.9.1 (which then pulls xml-apis 1.3.04). 
So we need to update xercesImpl to 2.9.1 too. Do you agree? 

> Xalan dependency should be updated
> ----------------------------------
>
>                 Key: FOP-2485
>                 URL: https://issues.apache.org/jira/browse/FOP-2485
>             Project: FOP
>          Issue Type: Wish
>    Affects Versions: 2.0
>            Reporter: Jochen Kemnade
>
> Fop 2.0 depends on Xalan 2.7.0 via {{batik-dom}}. Xalan 2.7.0 pulls in 
> {{xml-apis:2.0.2}}. That one overrides {{xml-apis:1.3.04}}, which is actually 
> *newer*. (see 
> http://swordsystems.com/2011/06/29/xerces-and-xml-api-dependency-hell/). 
> Updating Xalan to 2.7.2 fixes the issue.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to