Sankaranarayanan created FOP-2670:

             Summary: Unicode character (left arrow) is not displayed in PDF.It 
displayed as #
                 Key: FOP-2670
             Project: FOP
          Issue Type: Bug
          Components: fo/inline
    Affects Versions: 0.95
         Environment: Windows-7 and Fedora
            Reporter: Sankaranarayanan


I am using appache velocity and fop 0.20.5 version.

While generating pdf with FOP, the characters ←, →, ↑ are not corrctly 
displayed in the PDF. It get printed as # instead of this  →,→ ↑.   Actually my 
end users are copy pasting bulleted list from from Microsoft Word to my 
velocity form and save. Then they are expecting to see these special characters 
characters ←, →, ↑ in the pdf correctly.

In the fop root am using font-family="Times New Roman"

<fo:root font-family="Times Roman" font-size="11pt" 

When I tried to use the font family as "Symbol" it get printed as → correctly
In my case I need to display alpha numeric and unicode characters in the PDF.

So i tried to use  font-family="Times Roman,Symbol", but it did not work, still 
it shows as #.  

How to support multiple font family in fop. Kindly help me.

Thanks & Regards,


This message was sent by Atlassian JIRA

Reply via email to