[ 
https://issues.apache.org/jira/browse/FOP-2670?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15697754#comment-15697754
 ] 

Sankaranarayanan commented on FOP-2670:
---------------------------------------

Hi,

Sample Input1: Test data → 
The pdf shows: Test data # 

Sample Input2: Test data ←
The pdf shows: Test data # 

Sample Input3: Test data ↑
The pdf shows: Test data # 

Sample Input3: Test data ↓
The pdf shows: Test data # 

My end users are Genetic lab technicians. Since the symbol that used by these 
users for reporting in the velocity template is as per International standards, 
I need character support techniques in the velocity forms and its pdf. 
According to these users, each character has meaningful interpretation and they 
cant use my forms without that. 
For the smooth interpretation of the result, they copy paste the special 
characters from Microsoft word to the velocity template.

I am using MySQL 5.6.13 as backend and the above sample data gets saved in the 
database as 
Test data ←
Test data →       
Test data ↔       



Thanks & Regards,

Sankaranarayanan

> Unicode character (left arrow) is not displayed in PDF.It displayed as #
> ------------------------------------------------------------------------
>
>                 Key: FOP-2670
>                 URL: https://issues.apache.org/jira/browse/FOP-2670
>             Project: FOP
>          Issue Type: Bug
>          Components: fo/inline
>    Affects Versions: 0.95
>         Environment: Windows-7 and Fedora
>            Reporter: Sankaranarayanan
>
> Hi 
> I am using appache velocity and fop 0.20.5 version.
> While generating pdf with FOP, the characters ←, →, ↑ are not corrctly 
> displayed in the PDF. It get printed as # instead of this  →,→ ↑.   Actually 
> my end users are copy pasting bulleted list from from Microsoft Word to my 
> velocity form and save. Then they are expecting to see these special 
> characters characters ←, →, ↑ in the pdf correctly.
> In the fop root am using font-family="Times New Roman"
> <fo:root font-family="Times Roman" font-size="11pt" 
> xmlns:fo="http://www.w3.org/1999/XSL/Format";>
> When I tried to use the font family as "Symbol" it get printed as → correctly
> In my case I need to display alpha numeric and unicode characters in the PDF.
> So i tried to use  font-family="Times Roman,Symbol", but it did not work, 
> still it shows as #.  
> How to support multiple font family in fop. Kindly help me.
> Thanks & Regards,
> Sankaranarayanan



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to