[ 
https://issues.apache.org/jira/browse/FOP-2726?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16091432#comment-16091432
 ] 

vijay shankar commented on FOP-2726:
------------------------------------

we analysed and found to be an issue with this file: 
${JAVA_HOME}/jre/lib/cmm/sRGB.pf file. It exists in both installs Oracle JDK 
and OpenJDK although it’s a different size. 
Solved by copying the oracle version into the openjdk directory then it works 
as expected. 
I solved this issue on tomcat server by specifying the lookup path for these 
files via the sysprop: java.iccprofile.path.

Regards,
Vijay

> FOP 0.93 version has issue with image on tomcat server running with OpenJDK
> ---------------------------------------------------------------------------
>
>                 Key: FOP-2726
>                 URL: https://issues.apache.org/jira/browse/FOP-2726
>             Project: FOP
>          Issue Type: Bug
>          Components: image/png
>         Environment: Tomcat running with OpenJDK1.7
>            Reporter: vijay shankar
>            Priority: Blocker
>         Attachments: ErrorLog.log
>
>
> We have a web-application and are using FOP-0.93 to generate a pdf. We have 
> given path of a logo image in the template file as below.
> <fo:external-graphic src="image/logo.png" content-width="138pt" 
> content-height="125pt"/>.
>  When we are deploying war on local machine's tomcat(using jdk1.7), pdf is 
> being generated successfully with logo. But when same war file has deployed 
> on tomcat server(OpenJDK), getting NullPointerException. find the attached 
> log for more information.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to