[ 
https://issues.apache.org/jira/browse/FOP-2785?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

KuiLIU updated FOP-2785:
------------------------
    Description: 
The method seems to find an appropriate "Property" related to the 
fo.getNameId().
Thus, identifier "find" should be better than "make".
{code:java}
   /**
     * Set default precedence according to the parent FObj
     *
     * {@inheritDoc}
     */
     public Property make(PropertyList propertyList) throws PropertyException {
         FObj fo = propertyList.getFObj();
         switch (fo.getNameId()) {
         case Constants.FO_TABLE:
             return num6;
         case Constants.FO_TABLE_CELL:
             return num5;
         case Constants.FO_TABLE_COLUMN:
             return num4;
         case Constants.FO_TABLE_ROW:
             return num3;
         case Constants.FO_TABLE_BODY:
             return num2;
         case Constants.FO_TABLE_HEADER:
             return num1;
         case Constants.FO_TABLE_FOOTER:
             return num0;
         default:
             return null;
         }
     }
{code}


  was:
The method seems to find an appropriate "Property" related to the 
fo.getNameId().
Thus, identifier "find" should be better than "make".


> inconsistent method name "make"
> -------------------------------
>
>                 Key: FOP-2785
>                 URL: https://issues.apache.org/jira/browse/FOP-2785
>             Project: FOP
>          Issue Type: Improvement
>    Affects Versions: trunk
>            Reporter: KuiLIU
>            Priority: Major
>
> The method seems to find an appropriate "Property" related to the 
> fo.getNameId().
> Thus, identifier "find" should be better than "make".
> {code:java}
>    /**
>      * Set default precedence according to the parent FObj
>      *
>      * {@inheritDoc}
>      */
>      public Property make(PropertyList propertyList) throws PropertyException 
> {
>          FObj fo = propertyList.getFObj();
>          switch (fo.getNameId()) {
>          case Constants.FO_TABLE:
>              return num6;
>          case Constants.FO_TABLE_CELL:
>              return num5;
>          case Constants.FO_TABLE_COLUMN:
>              return num4;
>          case Constants.FO_TABLE_ROW:
>              return num3;
>          case Constants.FO_TABLE_BODY:
>              return num2;
>          case Constants.FO_TABLE_HEADER:
>              return num1;
>          case Constants.FO_TABLE_FOOTER:
>              return num0;
>          default:
>              return null;
>          }
>      }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to