Hannes Hartl commented on FOP-2947:

I kind a solved the problem.

I used FontForge to compare Frutiger and our new font.
Frutiger is encoded in Unicode BMP while the new font ist encoded in Unicode 
After encoding the new font with Unicode BMP it worked. At the moment I haven't 
done enough testing, so know, if all other things work at well.

> PDF fulltext is missing spaces and As
> -------------------------------------
>                 Key: FOP-2947
>                 URL: https://issues.apache.org/jira/browse/FOP-2947
>             Project: FOP
>          Issue Type: Bug
>          Components: renderer/pdf
>    Affects Versions: 1.0
>         Environment: Windows 10
> Apache FOP 1.0
> Saxon (don't know which version)
> Java (openjdk-13.0.1)
>            Reporter: Hannes Hartl
>            Priority: Major
>         Attachments: Full-Text-Example.txt, konventionen.pdf
> Hi
> we are converting XMLs to PDF.
> We were using Frutiger-Font but now we have to switch to a variant of Adobe 
> Source Sans. Both fonts are TTFs and used as embeded.
> Since we are using the new font, PDFs are created perfectly but the full text 
> of the PDF is missing spaces between words. 
> Additionally als big As are missing in the full text.
> This leads to the problem that twe (and our customers) are no longer able to 
> search the PDF full text correctly.
> Unfortunally the original developper of our converting environonment is no 
> longer working for the company.

This message was sent by Atlassian Jira

Reply via email to