Hi,

I'm currently trying to compile Fop-0.20.1-src.tar from xml.apache.org unter
w2k/sun jdk1.4beta2, but it says the following:

    [javac] E:\download\Programming\Java
API's\Fop-0.20.1-src.tar\Fop-0.20.1\bui
ld\src\org\apache\fop\svg\PDFGraphics2D.java:959: nested class
org.apache.fop.sv
g.PDFGraphics2D. PDFGraphicsConfiguration is an abstract class. It can't be
inst
antiated.
    [javac]         return new PDFGraphicsConfiguration();
    [javac]                ^
    [javac] E:\download\Programming\Java
API's\Fop-0.20.1-src.tar\Fop-0.20.1\bui
ld\src\org\apache\fop\svg\PDFGraphics2D.java:966: nested class
org.apache.fop.sv
g.PDFGraphics2D. PDFGraphicsConfiguration must be declared abstract. It does
not
 define java.awt.image.VolatileImage createCompatibleVolatileImage(int, int)
fro
m class java.awt.GraphicsConfiguration

and the build fails because of those two errors. I suppose that my ant
configuration is ok, because the compilation of xalan and xerces worked
fine, for me, it rather seems some mix-up in the sourcecode itself. I simply
call build.bat and do not have any other xerces/xalan compilation in my
CLASSPATH.

Can anyone reproduce that error or give me a pointer into the right
direction?

Thanks!
Sebastian

ps. Just downloaded fop-0.20.2RC2 and tried to compile that, same problem,
same location. Any suggestions? The binary distribution seems to work, but I
still wonder why the compile crashes.


Reply via email to