I posted this on the -dev list this morning and the more I thought about it
the more the -user list seemed more appropriate, and I am not sure how many
people who might be able to help cross-read.

Apologies for the duplicate copies for the folks who also read -dev.

James

-----Original Message-----
From: Higgins, James [mailto:[EMAIL PROTECTED]
Sent: Tuesday, March 26, 2002 10:14 AM
To: 'fop-dev@xml.apache.org'
Subject: Servlet problems



Ok, I have been messing with this problem for a day or so now and can't find
a reasonable solution.

I am using Tomcat 4.0.3 and FOP 0.20.3.  I have deployed the servlet into
the container and copied the fop.jar along with the other jars in the FOP
library directory to the servlets WEB-INF/lib directory.

I can producer documents containing plaintext with no problems.  

However, when I try to render the embedding.fo SVG example  I get the
following exception:

java.lang.NoClassDefFoundError: org/w3c/dom/svg/SVGPaint at
java.lang.ClassLoader.defineClass0(Native Method) at
java.lang.ClassLoader.defineClass(ClassLoader.java:509) at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123) at
org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLo
ader.java:1631) at
org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.jav
a:926) at
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.jav
a:1360) at org.apache.catalina.loader.WebappClassLoader.loadClass
.....

The class org.w3c.dom.svg.SVGPaint is located in batik.jar with the rest of
the jars.
Anyone have any clue what I am doing wrong?



---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

Reply via email to