I got fop successfully running on websphere 3.5 just by adding saxon.jar at the first place in the com.ibm.ejs.sm.adminserver.classpath record of admin.config file (beware about strange syntax \:/), here is my line (websphere 3.5.6, NT4):
com.ibm.ejs.sm.adminserver.classpath=d\:/WebSphere/AppServer/lib/saxon.jar;d\:/WebSphere/AppServer/lib/ibmwebas.jar;d\:/WebSphere/AppServer/properties;d\:/WebSphere/AppServer/lib/servlet.jar;d\:/WebSphere/AppServer/lib/webtlsrn.jar;d\:/WebSphere/AppServer/lib/lotusxsl.jar;d\:/WebSphere/AppServer/lib/compat.jar;d\:/WebSphere/AppServer/lib/xalan.jar;d\:/WebSphere/AppServer/lib/ns.jar;d\:/WebSphere/AppServer/lib/ejs.jar;d\:/WebSphere/AppServer/lib/ujc.jar;D\:/PROGRA~1/SQLLIB/java/db2java.zip;d\:/WebSphere/AppServer/lib/repository.jar;d\:/WebSphere/AppServer/lib/admin.jar;d\:/WebSphere/AppServer/lib/swingall.jar;d\:/WebSphere/AppServer/lib/console.jar;d\:/WebSphere/AppServer/lib/was20cm.jar;d\:/WebSphere/AppServer/lib/tasks.jar;d\:/WebSphere/AppServer/lib/xml4j.jar;d\:/WebSphere/AppServer/lib/vaprt.jar;d\:/WebSphere/AppServer/lib/sslight.jar;d\:/WebSphere/AppServer/lib/ibmjndi.jar;d\:/WebSphere/AppServer/lib/deployTool.jar;d\:/WebSphere/AppServer/lib/databeans.jar;d\:/WebSphere/
AppServer/classes;d\:/WebSphere/AppServer/jdk/lib/tools.jar;d\:/WebSphere/AppServer/lib/bsf.jar;d\:/WebSphere/AppServer/lib/dertrjrt.jar;d\:/WebSphere/AppServer/lib/derdbpw.jar;d\:/WebSphere/AppServer/lib/ivjejb35.jar;d:/WebSphere/AppServer/lib/js.jar;d\:/WebSphere/AppServer/lib/js.jar
This way saxon's SAX implementation classes override those in old libraries.


[EMAIL PROTECTED] wrote:
Thanks for your help. I got the following from my websphere administrator.

We've tried to do the changes as mentioned at the end of your e-mail
(changing jars and updating admin.config), but the IBM admin server can't
restart.

If we remove xml4j.jar  and the others and replace them by the ones
specified, the IBM admin server can't restart because of the lack of ibm
xml classes only found in xml4j.jar, and not available in Xerces-1.2.3.jar
or Xalan-2.0.0.

We've tried to use xml4j.jar with Xerces123 and Xalan200, but problems
appears in the running of the server.

ANy suggestions?

Thanks again for your help.

-Neeru



"J.Pietschman n" To: [EMAIL PROTECTED] <[EMAIL PROTECTED] cc: oo.de> Subject: Re: AW: Problem with servlet 06/21/2002 05:23 PM Please respond to fop-user




[EMAIL PROTECTED] wrote:

I made the changes but still getting the same error.
It's driving me crazy. ANy help will be greatly appreciated.


Usually, WebSphere 3.5 comes with an ancient XML tool set.
You have to put Xerces-1.2.3.jar and Xalan-2.0.0.jar into the
classpath before the old tools.
If you have admin access, remove xml4j.jar, a perhaps existing
old xerces.jar, lotusxsl.jar from the WebSphere lib and edit the
startup scripts so that the newer Xerces and Xalan jars are
used.
If you have user rights only, start the admin client, go
to your application server entry, open the "environment"
windoe and add a CLASSPATH environment variable with the
newer Xerces and Xalan jars .
Better yet, upgrade to 4.0.

J.Pietschmann








-- Oleg Tkachenko Multiconn International Ltd, Israel



Reply via email to