Rod,

> Here's the table that does what I'm talking about.  It's verbatim: no
> names have been changed; there are no innocent to protect.

Removed this: ' background-color="white"'
in several places & that seemed to fix the problem, (although the image
url's got 404's).

Cheers,
Roland.

> > When I specify the border at the table-column level, i.e.
> >
> > <fo:table-column column-number="1" column-width="20mm"
> > border-style="solid" />
> >
> > The border gets 'covered up' or perhaps overridden by the
> table cells.
>
> > That is, I can't see it in the table, but I know it's
> there, since if
> > I increase the width to, say, 3pt, I can see it sticking
> out over and
> > under the table itself.  But nothing within.
> >
> > If I specify the border at the table-cell level, i.e.
> >
> > <fo:table-cell border-left-style="solid" border-right-style="solid">
> >
> > then the border shows up, but I get little gaps between the
> borders on
>
> > each cell.  I presume that the rendering engine draws the top and
> > bottom borders over and under the side borders, so the gaps I'm
> > seeing reflect
> > the absence of the top and bottom border of the cell.
> >
> > I've played with many combinations of padding, setting it
> to 0, 1pt,
> > and 3pt for the column and cell level.
> >
> > I'm stumped!  Any suggestions?
>
> Yes, show us a small example.
>
> This works fine for me, ie no gaps, using pretty much the code you've
> described. I put the borders on the right side of cells only,
> padding on
> cells only & specified <fo:table border-collapse="separate" > if that
> matters.
>
> Cheers,
> Roland.
>
>
>
>
>

Reply via email to