I'm trying to retrieve values for a specific smart_class_variable via API,
but not getting any results. The user I am using to do this has the
'viewer' role which has worked in the past, but somewhere along the line it
stopped working - unfortunately I cant say which update exactly which
introduced the change.

I am now running on 1.12.2.

This is my request:

GET /api/smart_class_parameters/1426

A simple 'GET'. Results in:

{"message":"Smart class parameter not found by id '1426'"}

I have tried to add numerous types of permission filters to my user to no
luck. The only way I can get it to work is to tick the 'administrator' box
for the user.

Am I missing something here? Is it a bug or am I just doing it wrong?

Adam W

You received this message because you are subscribed to the Google Groups 
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to foreman-users+unsubscr...@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at https://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.

Reply via email to