There is a Smart Proxy listed and the URL: shows a page  with a Sinatra 
saying.  I do see the following Errors/Warnings:

TCPServer Error: Address already in use - bind(2)

OpenSSL::SSL::SSLError: SSL_accept returned=1 errno=0 state=SSLv3 read 
client certificate A: tlsv1 alert unknown ca 
/usr/share/ruby/openssl/ssl.rb:226:in `accept'

This is a brand new Foreman environment with a new VLAN and there are no 
other servers built.  There is only 1 server in this foreman install.

I noticed that some of the "foreman-installer" options have changed, has 
there been anything with the Smart Proxy Install that has changed?


On Thursday, October 13, 2016 at 4:35:10 PM UTC-5, Andrew Enstad wrote:
>
> Anyone else having issues with the install of Foreman 1.13?
>
> I have a Centos7 server that I have been trying to install Foreman 1.13, 
> but it errors out when it tries to do the initial Puppet Run.  
>
> Output from the foreman-installer:
>
> Running "puppet agent -t"...
> Warning: Unable to fetch my node definition, but the agent run will 
> continue:
> Warning: Error 400 on SERVER: Failed to find <hostname> via exec: 
> Execution of '/etc/puppet/node.rb <hostname>' returned 1:
> Info: Retrieving pluginfacts
> Info: Retrieving plugin
> Info: Loading facts
> Error: Could not retrieve catalog from remote server: Error 400 on SERVER: 
> Failed when searching for node <hostname>: Failed to find 
> foreman.quicksand.identix.com via exec: Execution of 
> '/etc/puppet/node.rb <hostname>' returned 1:
> Warning: Not using cache on failed catalog
> Error: Could not retrieve catalog; skipping run
> ERR: The puppet agent command has failed has failed.
>
> Output from /var/log/foreman/production.log:
>
> Oct 13 16:22:39 foreman puppet-master[7211]: Starting Puppet master 
> version 3.8.7
> Oct 13 16:22:39 foreman puppet-master[7226]: The environment must be 
> purely alphanumeric, not ''
> Oct 13 16:22:56 foreman puppet-master[7226]: Failed to find <hostname> via 
> exec: Execution of '/etc/puppet/node.rb <hostname>' returned 1:
> Oct 13 16:22:56 foreman puppet-agent[7261]: Unable to fetch my node 
> definition, but the agent run will continue:
> Oct 13 16:22:56 foreman puppet-agent[7261]: Error 400 on SERVER: Failed to 
> find <hostname> via exec: Execution of '/etc/puppet/node.rb <hostname>' 
> returned 1:
> Oct 13 16:22:56 foreman puppet-agent[7261]: Retrieving pluginfacts
> Oct 13 16:22:56 foreman puppet-agent[7261]: Retrieving plugin
> Oct 13 16:22:57 foreman puppet-agent[7261]: Loading facts
> Oct 13 16:22:59 foreman puppet-master[7226]: Failed when searching for 
> node <hostname>: Failed to find <hostname> via exec: Execution of 
> '/etc/puppet/node.rb <hostname>' returned 1:
> Oct 13 16:22:59 foreman puppet-master[7226]: Failed when searching for 
> node <hostname>: Failed to find <hostname> via exec: Execution of 
> '/etc/puppet/node.rb <hostname>' returned 1:
> Oct 13 16:22:59 foreman puppet-agent[7261]: Could not retrieve catalog 
> from remote server: Error 400 on SERVER: Failed when searching for 
> node <hostname>: Failed to find <hostname> via exec: Execution of 
> '/etc/puppet/node.rb <hostname>' returned 1:
> Oct 13 16:22:59 foreman puppet-agent[7261]: Not using cache on failed 
> catalog
> Oct 13 16:22:59 foreman puppet-agent[7261]: Could not retrieve catalog; 
> skipping run
>
>
>

-- 
You received this message because you are subscribed to the Google Groups 
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to foreman-users+unsubscr...@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at https://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.

Reply via email to