Hi Antti,
I downloaded the synergy source package from the URL below to both our internal 
fossology repository and the public external instance at repo.fossology.org.  
Both ran to completion; results are here:  

Since I can't reproduce your results, my next best guess is your installation 
(or upgrade) for 1.4.1 did not complete successfully.  Can you please check 
your fossology.log file and the postgres log file for errors or other clues 
that might indicate what's wrong?

Did you install from source or packages?  A fresh install or upgrade?

You may want to re-run /usr/lib/fossology/fo-postinstall and see if it 
complains about anything.


From: Laser, Mary
Sent: Wednesday, June 29, 2011 9:31 AM
To: 'Antti Luoto'; 'fossology@fossology.org'
Subject: RE: [FOSSology] Viewing the contents of individual files in Synergy 
package fails

Hi Antti,
Thanks for filing the bug report.  I will download your package and attempt to 
reproduce the error.  I'll send an update later today.


From: fossology-boun...@fossology.org [mailto:fossology-boun...@fossology.org] 
On Behalf Of Antti Luoto
Sent: Wednesday, June 29, 2011 6:13 AM
To: 'fossology@fossology.org'
Subject: [FOSSology] Viewing the contents of individual files in Synergy 
package fails

I made a bug report (http://bugs.linux-foundation.org/show_bug.cgi?id=833) with 
the following text:


We uploaded Synergy (http://synergy-foss.org/) source packages to Fossology 
(1.4.1 rc 1) running on Linux Ubuntu 10.04. The license browser seems to work 
well until, when trying to view the individual file contents, Fossology shows 
an error message:

"File contents are not available in the repository.
This file is unpacked from [synergy-1.3.7-Source.tar.gz]
Reunpack: synergy-1.3.7-Source.tar.gz"

A direct link to the package is here:

After noticing the problem we tried the same thing with packages
http://synergy-foss.org/nightly/synergy-1.3.7-r1041-Source.tar.gz and
still achieving the same results.

An interesting detail was, that files with license match X11 could be viewed 

We have also tried reunpacking, deleting and reuploading the package without 
In addition, it seems that all the other packages are working normally.

Does anyone have any ideas how to get the file contents visible in Fossology? 
Of course it is possible to browse the files under a certain license locally, 
as the license matching information is available, but it is not very efficient.
Who's Who Legal: Leading expertise at HH Partners. See 
Privileged and confidential information may be contained in this message. If 
you are not addressee indicated in this message (or responsible for delivery of 
the message to such person), you may not copy or deliver this message to 
anyone. In such case, kindly notify us by reply e-mail and delete this message 
immediately. Thank you.
fossology mailing list

Reply via email to