Hanno Schlichting wrote:
Daniel Nouri wrote:
Do you agree that we put the documentation in the top-level directory?
I.e. INSTALL.txt, README.txt etc. They shouldn't really go *inside*
the package I hear from Ian. Would also give us less duplication
between the plone_app and the plone_core (should we rename?) templates.
I think that for distribution (project) names we should use names like
"PloneExample", rather than "plone.example".
We can put the docs at the top level. I just put them inside the package
as we always did it this way, but after thinking about it, this was only
because we had no other choice ;)
The name plone_core is misleading now indeed. We could rename it to
either just plone or plone_base. I think plone_app is fine.
+1 for just plone
For distribution names I'm against using upper- or CamelCase names.
While it is not technically a Python module, it is of a folderish nature
and thus should use all lowercase names.
Besides using these lowercase names is already practiced by the Zope
people in general. Look at http://svn.zope.org for things like
'zope.interface', 'zc.recipe.filestorage', ...
I fear having a different naming convention for distributions would
confuse people more than it would help.
The problem here is that Zope 3 is not following the convention... I'm
not sure if that's a good enough reason for us to do the same.
Framework-Team mailing list