Hanno Schlichting wrote:
Daniel Nouri wrote:
Do you agree that we put the documentation in the top-level directory?
I.e. INSTALL.txt, README.txt etc. They shouldn't really go *inside*
the package I hear from Ian. Would also give us less duplication
between the plone_app and the plone_core (should we rename?) templates.
I think that for distribution (project) names we should use names like
"PloneExample", rather than "plone.example".
We can put the docs at the top level. I just put them inside the package
as we always did it this way, but after thinking about it, this was only
because we had no other choice ;)
The name plone_core is misleading now indeed. We could rename it to
either just plone or plone_base. I think plone_app is fine.
For distribution names I'm against using upper- or CamelCase names.
While it is not technically a Python module, it is of a folderish nature
and thus should use all lowercase names.
I personally prefer camel case, specifically because it distinguishes
between the Python package and the distribution, which is a subtle
distinction that can be easy to confuse otherwise. That said, for
another new package I'm using "topp.zwsgi" as the distribution name,
because its actually a good contrast to "topp/zwsgi/" which is where the
actual Python code is going. Since it seems like Plone is favoring
deeper namespaces, it might not be a big deal. At one point
distribution names with .'s and other punctuation weren't working well
with PyPI, but that seems to have been resolved.
Incidentally, Cheese Cake is trying to build up package layout
conventions: http://pycheesecake.org/ -- they were going to build a
hello world package representing an ideal package layout, but I don't
see one in the repository.
Ian Bicking | [EMAIL PROTECTED] | http://blog.ianbicking.org
Framework-Team mailing list