On 5 May 2009, at 13:20, Martin Aspeli wrote:

<snip>

Yes, I agree with all of these, and do think they're needed.

So, 3.5 is a compromise. The skipping of 3.4 actually helps back the story up. We could try something else, like Plone 2009, but I'm pretty sure we'd regret that in 2010 for one reason or another. And PyPI wouldn't like it.

That's true, I am very nervous about the Plone 3.x compatibility becoming >=3.0,<3.5-dev though - it is a change in policy to what we've previously said and I do think it would catch people out.

I had some issues with mails bouncing as I'm subscribed with different addresses to different lists, so, to reiterate, if we keep Plone 3.3 supported and make it clear that there's a significant difference between 3.3 and 3.5, then I'm +0. I'd only be +1 if we could make that explicit in the name. This is not because of the proposal, I'm very much in favour of the proposal in principle, it's just the fact we lose our easy-to-understand compatibility promise by making a decision very much like the one we made in Plone 2.5.

Yeah, thanks for helping. :p

There may well not be a name that would satisfy me. I can't think of one, you can't think of one, there may just not be one.

I think that'd be the case under the "two supported versions" policy.


But that would mean that when 4.0 comes out 3.<5 becomes unsupported completely. Is that desirable?

I'm not trying to be an arse here Martin, really, I'm just concerned about 3.x users. We've managed to remove a lot of fear from upgrades in the 3.x series, I don't want to lose that.

Matt

_______________________________________________
Framework-Team mailing list
Framework-Team@lists.plone.org
http://lists.plone.org/mailman/listinfo/framework-team

Reply via email to