On Aug 10, 2009, at 11:36 AM, Wichert Akkerman wrote:
On 8/10/09 11:33 , Andreas Zeidler wrote:
On Aug 7, 2009, at 3:47 PM, Alec Mitchell wrote:
OTOH, we could
simply declare that we're OK with breaking backwards compatibility
here if we have consensus that this is worthwhile. Perhaps we should
vote on this or discuss on the next call.


please do. otoh, if we don't want to break it, we should at least
deprecate the old way and then drop it in 5.0, or perhaps even in
something like 4.2.

4.x should be like 3.x, which means you can not drop something in 4.2. You can deprecate in 4.2 though. I'm not sure if you mean the first or the latter here.

i actually meant the first, but you're right. so we should either make the change for 4.0, or else we'll have to wait until 5.0. i'd be in favour of the first option... :)


andi

--
zeidler it consulting - http://zitc.de/ - i...@zitc.de
friedelstra├če 31 - 12047 berlin - telefon +49 30 25563779
pgp key at http://zitc.de/pgp - http://wwwkeys.de.pgp.net/
plone 3.3rc5 released! -- http://plone.org/products/plone/

Attachment: PGP.sig
Description: This is a digitally signed message part

_______________________________________________
Framework-Team mailing list
Framework-Team@lists.plone.org
http://lists.plone.org/mailman/listinfo/framework-team

Reply via email to