As Ian Smith wrote:

> Your dmesg will show whether eg acpi_throttle is enabled.  If it is and 
> no other relative driver takes over (as p4tcc would on many Intels), 
> then acpi_throttle will jump in and generate lots of such freqs.

Yes, I can see acpi_throttle there.  I'm attaching the boot messages
for reference.

> I don't know about Turions at all, but we're seeing dual and quad
> core Intels that seem to get no benefit and apparently real
> detriment by enabling throttling nowadays, especially in hope of
> saving power/heat.  Or rather, possible detriment by not disabling
> it as it defaults on.

Could you translate that into English? ;-)

I can at least notice a dramatically reduced fan activity while the
machine is idle.  Alas, the ACPI BIOS (or the battery pack) there is
too stupid to measure the power consumption, so I cannot directly tell
how much might be saved.

> For Intels, advice has been to add to loader.conf:
>   hint.p4tcc.0.disabled=1
>   hint.acpi_throttle.0.disabled=1
> (per cpu) in loader.conf to retain just the absolute frequency set.

OK, I can disable acpi_throttle at the next boot, currently my kids
are using it so I won't like to kill the machine. ;-)

> As for bin/136354 and bin/145063, personally I preferred a patch
> adding debug.cpufreq.highest to the existing debug.cpufreq.lowest,
> allowing more dynamic min/max range setting by sysctl rather than
> having to restart powerd with new parameters, but it was said to be
> poor policy.

I think separate frequency bounds for AC/battery operation
(bin/136354) are preferrable (at least provided lower frequencies can
really reduce the power consumption), as they might increase battery
life.  What I don't like in bin/136354 though is the naming of the
options.  Maybe we should rather append optional arguments to the
option arguments (:-) for -a and -b, respectively?

Like:

powerd -a hadp,800,2000 -b adp,50,1000

I think that's better to understand for a human than

powerd -a hadp -c 800 -d 2000 -b adp -e 50 -f 1000

yet still gives finer-grained control than (bin/145063):

powerd -a hadp -b adp -m 50 -M 2000

[machine works now]

> But you still have all those freqs?  And no acpi_throttle in dmesg?

Yes, I do, but as mentioned, it's with acpi_throttle.  Will post
non-acpi_throttle values later on (alas, you might already be asleep
then).

> Sounds good, but still better to know what did the trick, for next time.

I wish I knew, yes.  OTOH, I'm more than happy the machine is now
operational, and doesn't have to run at full steam even while idle, or
just freeze when running on batteries for a few minutes (previously, I
tried powerd with -a max -b adp, which made it freeze when running on
battery power).  A frozen computer is always frustrating in particular
for the kids.

-- 
cheers, J"org               .-.-.   --... ...--   -.. .  DL8DTL

http://www.sax.de/~joerg/                        NIC: JW11-RIPE
Never trust an operating system you don't have sources for. ;-)
Copyright (c) 1992-2010 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 8.0-STABLE #1 r207158: Sat Apr 24 23:20:58 CEST 2010
    r...@erwin.local.heep.sax.de:/usr/obj/usr/src/sys/ERWIN i386
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Turion(tm) 64 Mobile Technology MT-37 (800.03-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x20f42  Family = f  Model = 24  Stepping = 2
  
Features=0x78bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2>
  Features2=0x1<SSE3>
  AMD Features=0xe2500800<SYSCALL,NX,MMX+,FFXSR,LM,3DNow!+,3DNow!>
  AMD Features2=0x1<LAHF>
real memory  = 1073741824 (1024 MB)
avail memory = 1041412096 (993 MB)
kbd1 at kbdmux0
acpi0: <A M I OEMXSDT> on motherboard
ACPI: Overriding _OS definition with "Linux"
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 3ff00000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_ec0: <Embedded Controller: GPE 0> port 0x62,0x66 on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <base peripheral, interrupt controller> at device 0.5 (no driver attached)
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pcib2: <ACPI PCI-PCI bridge> irq 10 at device 2.0 on pci0
pci2: <ACPI PCI bus> on pcib2
vgapci0: <VGA-compatible display> port 0xb000-0xb0ff mem 
0xb0000000-0xb7ffffff,0xfeaf0000-0xfeafffff irq 10 at device 0.0 on pci2
pcib3: <ACPI PCI-PCI bridge> irq 10 at device 3.0 on pci0
pci3: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> irq 10 at device 3.2 on pci0
pci5: <ACPI PCI bus> on pcib4
pci0: <serial bus, FireWire> at device 8.0 (no driver attached)
re0: <RealTek 8169/8169S/8169SB(L)/8110S/8110SB(L) Gigabit Ethernet> port 
0xe800-0xe8ff mem 0xfebff400-0xfebff4ff irq 5 at device 9.0 on pci0
re0: Chip rev. 0x10000000
re0: MAC rev. 0x00000000
miibus0: <MII bus> on re0
rgephy0: <RTL8169S/8110S/8211B media interface> PHY 1 on miibus0
rgephy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 
1000baseT-FDX, auto
re0: Ethernet address: 00:03:0d:35:a7:8f
re0: [FILTER]
pci0: <network> at device 10.0 (no driver attached)
atapci0: <VIA 6420 SATA150 controller> port 
0xec00-0xec07,0xe480-0xe483,0xe400-0xe407,0xe080-0xe083,0xe000-0xe00f,0xd800-0xd8ff
 irq 3 at device 15.0 on pci0
atapci0: [ITHREAD]
ata2: <ATA channel 0> on atapci0
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci0
ata3: [ITHREAD]
atapci1: <VIA 8237 UDMA133 controller> port 
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xfc00-0xfc0f at device 15.1 on pci0
ata0: <ATA channel 0> on atapci1
ata0: [ITHREAD]
ata1: <ATA channel 1> on atapci1
ata1: [ITHREAD]
pci0: <serial bus, USB> at device 16.0 (no driver attached)
pci0: <serial bus, USB> at device 16.1 (no driver attached)
pci0: <serial bus, USB> at device 16.2 (no driver attached)
pci0: <serial bus, USB> at device 16.3 (no driver attached)
pci0: <serial bus, USB> at device 16.4 (no driver attached)
isab0: <PCI-ISA bridge> at device 17.0 on pci0
isa0: <ISA bus> on isab0
pcm0: <VIA VT8237> port 0xc800-0xc8ff irq 3 at device 17.5 on pci0
pcm0: [ITHREAD]
pcm0: <Unknown AC97 Codec (id = 0x56494182)>
pcm0: <VIA DXS Enabled: DXS 4 / SGD 1 / REC 1>
pci0: <simple comms> at device 17.6 (no driver attached)
acpi_button0: <Sleep Button> on acpi0
acpi_button1: <Power Button> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
acpi_acad0: <AC Adapter> on acpi0
battery0: <ACPI Control Method Battery> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: [ITHREAD]
psm0: model Synaptics Touchpad, device ID 3
pmtimer0 on isa0
orm0: <ISA Option ROM> at iomem 0xce800-0xcf7ff pnpid ORM0000 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
powernow0: <PowerNow! K8> on cpu0
Timecounter "TSC" frequency 800034847 Hz quality 800
Timecounters tick every 1.000 msec
ad0: 152627MB <SAMSUNG HM160HC LQ100-10> at ata0-master UDMA100 
acd0: DVDR <NEC DVD+/-RW ND-6650A/1.42> at ata1-master UDMA33 acpi_ec0: wait 
timed out (response), forcing polled mode

Trying to mount root from ufs:/dev/ad0s1a
_______________________________________________
freebsd-acpi@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-acpi
To unsubscribe, send any mail to "freebsd-acpi-unsubscr...@freebsd.org"

Reply via email to