Hi all
Could you please help me with a little annoying problem concerning
laptop backlight?
I've got ASUS U46E laptop with Intel GMA graphics running FreeBSD 9-STABLE amd64. The problem is that backlight is always set to maximum value. Pressing Fn+F5 (brightness down) has no effect, just yielding the following to /var/log/messages:


ACPI Error: Result stack is empty! State=0xfffffe00017fa800
(20110527/dswstate-113)
ACPI Exception: AE_AML_NO_RETURN_VALUE, Missing or null operand
(20110527/dsutils-695)
ACPI Exception: AE_AML_NO_RETURN_VALUE, While creating Arg 0
(20110527/dsutils-821)
ACPI Error: Method parse/execution failed [\_SB_.PCI0.GFX0.GCBL] (Node
0xfffffe000181f600), AE_AML_NO_RETURN_VALUE (20110527/psparse-560)

This happens both in console and X Window mode

What I've tried:

1) Flashed the latest BIOS version from ASUS website (ver301)

2) Upgraded OS to the latest STABLE version (last upgrade Oct 2 2013)

3) Loading acpi_asus module:
     # kldload acpi_asus
     # sysctl -a | grep asus
     #

4) Loading acpi_video module:
    # sysctl hw.acpi.video.lcd0.active=1
     hw.acpi.video.lcd0.active: 0 -> 0
     # sysctl hw.acpi.video.lcd0.fullpower=60
     hw.acpi.video.lcd0.fullpower: 100 -> 60
     # sysctl hw.acpi.video.lcd0.economy=60
     hw.acpi.video.lcd0.economy: 77 -> 60
     # sysctl hw.acpi.video.lcd0.brightness=60
     hw.acpi.video.lcd0.brightness: 60 -> 60
Values are changed but brightness doesn't

5) Using acpi_call utility (not sure what value should be changed, tried
acpi_call -p '\_SB_.PCI0.GFX0.GCBL' and acpi_call -p
'\_SB_.PCI0.LPCB.EC0_._Q0E' -- both resulting in Unknown object type '0')

6) Writing to freebsd-questions@freebsd org -- no replies so far

# uname -a
FreeBSD toysrv 9.2-STABLE FreeBSD 9.2-STABLE #0 r255986: Wed Oct 2 13:15:20 EEST 2013 oomka@toysrv:/usr/obj/usr/src/sys/TOYSRV amd6

# acpidump -dt > u46e.asl
[gzipped file attached]

I used to run i386 FreeBSD on this laptop -- the brightness control was
okay on it. There were often kernel panics on that architecture so I've
switched to amd64. Panics disappeared and the things work fine so far,
except the screen brightness.
I know that my problem isn't critical when I'm working on daylight or
with external LCD display, but when I have to work at the laptop at
night -- this spotlight really drives me crazy. Thank you in advance for
your help.



_______________________________________________
freebsd-acpi@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-acpi
To unsubscribe, send any mail to "freebsd-acpi-unsubscr...@freebsd.org"

Reply via email to