Hi,  
  
I just bought a Lenovo Thinkpad T450 laptop and installed FreeBSD on top of it. 
It runs fine except I'm not able to change the display backlight. The laptop 
embeds a Core i5-5300U CPU with an Intel Graphics 5500 adapter (Broadwell). I 
know the adapter is not yet supported, but I hoped to have backlight control 
working anyway!  
  
Backlight control is working fine with OpenBSD 5.9, Linux 4.1+ and Windows, 
which is not very surprising as those OSes also support the display adapter. 
It's not working on FreeBSD 10.3-RELEASE nor 11.0-ALPHA6.  
  
What I have tried:  
  - I tried to load acpi_ibm and acpi_video kernel modules and tweak the sysctl 
they provide: I was able to modify the systctl values, but backlight remained 
the same.  
  - I also tried to install graphics/intel-backlight. There again: I was able 
to change values, but it didn't change the backlight.  
  - I tried to load the i915kms intel modul, just in case backlight control 
needed this to work properly. As before, no effect. I think the module is just 
ignoring my adapter as it does not support it.  
  
I'm ready to cope with the VESA driver for some time but I'd really like to get 
backlight control working. Do you have suggestions ? Is there anything I can do 
to help ?  
  
I use the UEFI framebuffer with vt in graphics mode. I did not try to run Xorg 
yet. Should I do it ?  
  
Thanks,  
  
--Marin  
  

_______________________________________________
freebsd-acpi@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-acpi
To unsubscribe, send any mail to "freebsd-acpi-unsubscr...@freebsd.org"

Reply via email to