https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=221385

            Bug ID: 221385
           Summary: [Regression] v6 mapped v4 addresses not working in
                    11.1
           Product: Base System
           Version: 11.1-RELEASE
          Hardware: Any
                OS: Any
            Status: New
          Keywords: regression
          Severity: Affects Only Me
          Priority: ---
         Component: kern
          Assignee: freebsd-bugs@FreeBSD.org
          Reporter: s...@struchtrup.com
          Keywords: regression

Created attachment 185224
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=185224&action=edit
Test case to reproduce the problem

Having set sysctl net.inet6.ip6.v6only=0, v6-mapped v4 addresses used to work
on 11.0 and on previous versions.

On 11.1-RELEASE, I am now getting EAFNOSUPPORT on connect() when using a
v6-mapped address on a PF_INET6 socket.

Adding an extra setsockopt to clear IPV6_V6ONLY will work around this.


# sysctl net.inet6.ip6.v6only
net.inet6.ip6.v6only: 0

# uname -a
FreeBSD s5.struchtrup.com 11.1-RELEASE FreeBSD 11.1-RELEASE #0 r321309: Fri Jul
21 02:08:28 UTC 2017    
r...@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

truss output (stripped) - failing case w/o setsockopt:

socket(PF_INET6,SOCK_STREAM,0)                   = 3 (0x3)
connect(3,{ AF_INET6 [::ffff:127.0.0.1]:1234 },28) ERR#47 'Address family not
supported by protocol family'


truss output with setsockopt:

socket(PF_INET6,SOCK_STREAM,0)                   = 3 (0x3)
setsockopt(3,IPPROTO_IPV6,IPV6_V6ONLY,0x7fffffffea94,4) = 0 (0x0)
connect(3,{ AF_INET6 [::ffff:127.0.0.1]:1234 },28) = 0 (0x0)

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
freebsd-bugs@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-bugs
To unsubscribe, send any mail to "freebsd-bugs-unsubscr...@freebsd.org"

Reply via email to