https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=297626

            Bug ID: 297626
           Summary: nfs mount of a NFSv3 share will hang if "Permission
                    denied"
           Product: Base System
           Version: 15.0-RELEASE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: kern
          Assignee: [email protected]
          Reporter: [email protected]

On a very idle x86_64 system running FreeBSD-15.0-RELEASE the
command to mount an NFSv3 share will hang if "Permission denied" :


hydra# freebsd-version -kru
15.0-RELEASE-p12
15.0-RELEASE-p12
15.0-RELEASE-p12
hydra# uname -apKU
FreeBSD hydra 15.0-RELEASE-p12 FreeBSD 15.0-RELEASE-p12
releng/15.0-n281099-7b527b9b97ba GENERIC amd64 amd64 1500068 1500068
hydra# 
hydra# sysctl hw.physmem
hw.physmem: 17003057152
hydra# sysctl hw.ncpu
hw.ncpu: 2
hydra# sysctl hw.model
hw.model: Intel(R) Pentium(R) CPU G4500 @ 3.50GHz
hydra# 

hydra# mkdir /mnt/pluto
hydra# mount -o ro pluto:/opt/bulk/passport /mnt/pluto
[tcp] pluto:/opt/bulk/passport: Permission denied


^C
hydra# echo $?
130

I did wait a minute. Seems to me that if the client does not have
permission to access the NFSv3 share then I would get the error
message instantly and the error code 130. Why the hang time?

-- 
You are receiving this mail because:
You are the assignee for the bug.

Reply via email to