On Sat, Nov 05, 2011 at 07:37:48AM -0700, m...@freebsd.org wrote: > On Sat, Nov 5, 2011 at 7:13 AM, Kostik Belousov <kostik...@gmail.com> wrote: > > On Fri, Nov 04, 2011 at 06:03:39PM +0200, Kostik Belousov wrote: > > > > Below is the KBI patch after vm_page_bits_t merge is done. > > Again, I did not spent time converting all in-tree consumers > > from the (potentially) loadable modules to the new KPI until it > > is agreed upon. > > I like my bikeshed orange... > > I would think a more canonical name would be get/set rather than > read/write, especially since these operations aren't reading and > writing the page (neither are they getting the page, but at least set > is pretty unambiguous). Look at the vm_page.h:385. vm_page_set_valid() is already taken.
Description: PGP signature