I had a previously discussed zpool related error on my susytem:
This may be related.

Now a different but equally odd error: On one of the pools with the import
problem (poolname=da), I had:
zfs set sharenfs="-network=" da/data/amd64
When I start nfsd + mountd, TTY0 shows this error:
bad exports list line: /mnt/data/amd64
bad exports list line: /mnt/amd64

I can only assume that I had the da zpool mounted as altroot=/mnt at some
point in its history. After I 
zfs set sharenfs=off da/data/amd64 
for debugging, the error persisted for some time then was gone when I first
tried; now it persists even after a pool scrub. ZDB shows nothing odd with
the "-Cl /dev/ada1p2" flag, but,
zdb -d da/data/amd64
zdb: can't open 'da/data/amd64': No such file or directory
I have same error for all pool-type commands. "# zdb -C da" for example.


View this message in context: 
Sent from the freebsd-current mailing list archive at Nabble.com.
freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to