2013/12/13 Jean-Sébastien Pédron <dumbb...@freebsd.org>:
> On 10.12.2013 12:21, Markiyan Kushnir wrote:
>> Hello,
>
> Hi!
>
> First, a quick note: freebsd-current@ and current@ are the same list.
>

thanks, I will know now.


>> There seems to be a difference in how Xorg server can use direct
>> rendering depending when radeonkms.ko was loaded: at boot time vs. at
>> a later time (but not necessarily at X startup time). The difference
>> is that direct rendering could not be enabled for X in the former
>> case. In the latter case, direct rendering was successfully enabled.
>
> The problem is that if you load radeonkms from the loader or you build
> it into your kernel, it can't load the relevant firmware(s):
> error: [drm:pid0:r600_init_microcode] *ERROR* r600_cp: Failed to load
> firmware "radeonkmsfw_RV710_pfp"
> error: [drm:pid0:rv770_startup] *ERROR* Failed to load firmware!
>
> This is because /boot isn't available at the time the card is
> initialized: / is not mounted yet.
>
> The solution is to load firmware(s) from the loader too (or build them
> into the kernel). To know which firmware(s) are used by your card, you
> can boot without radeonkms, kldload it after the computer booted, and run:
>   kldstat | grep radeonkmsfw
>

yes, it turns out that the issue was logged in dmesg, and I should
have noticed it.

Thanks agian, Jean-Sébastien

--
Markiyan.

> --
> Jean-Sébastien Pédron
>
_______________________________________________
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to