Did my weekly update of -CURRENT today to r261350 from r261236. After the
upgrade when I tried to run 'pkg' I got the error:

libelf.so.1 required by libpkg.so.1

So, I reinstalled 'pkg', which fixed the problem. Then I ran pkg_libchk to
see if any other libs were missing and got:

glib -2.36.3_1: /usr/local/bin/gresource misses libelf.so.1

So i re-installed glib and re-ran pkg_libchk against it. No more missing

Anyway, I'm wondering if I inadvertently deleted libelf.so.1 during the
'make delete-old' or 'make delete-old-libs' steps of the rebuild.
Unfortunately, these are the only two steps of the build process
(mergemaster excepted) that I do not 'script' the output, so I cannot go
back to see if that is the case. Obviously I need to begin "script'ing
these two steps on future builds.

Anyone else seen this or that can confirm an inadvertent delete of
libelf.so.1 on my part?

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to