On Sat, Feb 01, 2014 at 09:55:07PM +0100, Joel Dahl wrote:
> 1 feb 2014 kl. 21:52 skrev Thomas Hoffmann <trh...@gmail.com>:
> > Did my weekly update of -CURRENT today to r261350 from r261236. After the
> > upgrade when I tried to run 'pkg' I got the error:
> > 
> > libelf.so.1 required by libpkg.so.1
> > 
> > So, I reinstalled 'pkg', which fixed the problem. Then I ran pkg_libchk to
> > see if any other libs were missing and got:
> > 
> > glib -2.36.3_1: /usr/local/bin/gresource misses libelf.so.1
> > 
> > So i re-installed glib and re-ran pkg_libchk against it. No more missing
> > libelf.so.1.
> > 
> > Anyway, I'm wondering if I inadvertently deleted libelf.so.1 during the
> > 'make delete-old' or 'make delete-old-libs' steps of the rebuild.
> > Unfortunately, these are the only two steps of the build process
> > (mergemaster excepted) that I do not 'script' the output, so I cannot go
> > back to see if that is the case. Obviously I need to begin "script'ing
> > these two steps on future builds.
> > 
> > Anyone else seen this or that can confirm an inadvertent delete of
> > libelf.so.1 on my part?
> I’m seeing the same thing.

pkg is also linked to libelf.so.1 so to have it working you should use
pkg-static, waiting for the next builds on the clusters.o

We needs to update the jails of the cluster to reflect that change.

As a reminder for committers, before breaking any abi, Always warn portmgr about
it so we can prepare the cluter to build packages on the new ABI!


Attachment: pgp_bYL8gDiVI.pgp
Description: PGP signature

Reply via email to