On Tuesday, December 24, 2013 12:20:56 PM Roger Pau Monne wrote:
> Use madt_setup_io (from madt.c) on Xen apic_enumerator, in order to
> parse the interrupt sources from the IO APIC.
> I would like to get opinions, but I think we should rename and move
> madt_setup_io to io_apic.c.
It wouldn't be appropriate for io_apic.c as it isn't generic to I/O
APICs but is specific to ACPI. However, mptable.c is really not a
great name for this file in sys/x86/xen. I wonder if it should be
xen_apic.c instead? Also, if Xen PV has an MADT table, why do you
need a custom APIC enumerator at all? That is, what is preventing
the code in madt.c from just working? Do you just not have
'device acpi' in the kernel config you are using?
email@example.com mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"