The port x11/kde-workspace (kde-workspace-4.10.5_2 on my installation) fails to 
be updated
and therefore a bunch of very important applications (i.e. devel/kdevelop) do 
not work

The build/update of x11/kde4-workspace failst due to:

[ 98%] Built target kwin
gmake[4]: Entering directory `/usr/ports/x11/kde4-workspace/work/.build'
Scanning dependencies of target kwin_gles
gmake[4]: Leaving directory `/usr/ports/x11/kde4-workspace/work/.build'
gmake[4]: Entering directory `/usr/ports/x11/kde4-workspace/work/.build'
[ 98%] Building CXX object kwin/CMakeFiles/kwin_gles.dir/kwin_gles_dummy.cpp.o
Linking CXX executable kwin_gles
[ 98%] Building CXX object 

===>>> /usr/local/lib/ undefined reference to `_glapi_get_dispatch'
===>>>/usr/local/lib/ undefined reference to `_glapi_Dispatch'

c++: error: linker command failed with exit code 1 (use -v to see invocation)
gmake[4]: *** [kwin/kwin_gles] Error 1
gmake[4]: Leaving directory `/usr/ports/x11/kde4-workspace/work/.build'
gmake[3]: *** [kwin/CMakeFiles/kwin_gles.dir/all] Error 2
gmake[3]: *** Waiting for unfinished jobs....
[ 98%] Building CXX object 
[ 98%] Building CXX object 
[ 98%] Building CXX object 
[100%] Building CXX object 
[100%] Building CXX object 
[100%] Building CXX object
kmenuedit/CMakeFiles/kdeinit_kmenuedit.dir/kmenueditadaptor.cpp.o [100%] 
Building CXX
object kmenuedit/CMakeFiles/kdeinit_kmenuedit.dir/khotkeys_interface.cpp.o 
Linking CXX
shared library ../lib/ gmake[4]: Leaving directory
`/usr/ports/x11/kde4-workspace/wographics/libglesvrk/.build' [100%] Built target
kdeinit_kmenuedit gmake[3]: Leaving directory 
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/ports/x11/kde4-workspace/work/.build'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

make[1]: stopped in /usr/ports/x11/kde4-workspace

I tried to reinstall port graphics/libglesv2 via

portmaster -f graphics/libglesv2

to ensure no fault at this port, but the error still remains.

Do I miss something? In the past, I tried to find all the ports which needed to 
recompiled due to C++ library version bump-up.

Is there a fast solution for this? What is going wrong?

Thanks in advance,

Oliver Hartmann

Attachment: signature.asc
Description: PGP signature

Reply via email to