On 02/26/14 19:57, Don Lewis wrote:
> On 26 Feb, Michael Butler wrote:
>> On 02/18/14 12:10, Michael Butler wrote:
>>> Is anyone else seeing firefox failing to install after the clang-3.4
>>> merge? As in xpcshell dumping core ..
>> An update ..
>> Recompiling with GCC48 on -current yields the same result. Seems to run
>> correctly when invoked from the command-line but seg-faults with "errno
>> = 4" (invalid instruction) from the build
>> Giving up and using the Linux port .. :-(
> I've also seen this problem with clang-3.4 on i386.  It looks like a
> clang bug to me.  Clang is putting ud2 instructions in its output which
> are guaranteed to fault when it compiles nsAppRunner.cpp.  See
> <http://www.freebsd.org/cgi/query-pr.cgi?pr=187103>.
> I tried compiling the offending file with gcc46 and didn't see the
> problem in the assembly output.

<sigh> .. way back in the late 70's or maybe early 80's when I was
actually doing some work on compilers, we had a saying: "produce correct
code even if it's not optimal or exit and tell the user why".

Producing non-working code for no apparent reason and without warning is
counter-productive. It wastes everyone's time :-(


freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to