Peter Jeremy wrote this message on Fri, Jul 04, 2014 at 21:27 +1000:
> On 2014-Jul-04 02:28:48 -0700, John-Mark Gurney <> wrote:
> >So, I recently tried to break into the debugger w/ the various key
> >sequences that I know about, and none of them worked... I've tried
> >CTRL-ALT-PRTSCR, and many other different ones...   I've verified that
> >I can sysctl debug.kdb.enter=1 to enter the debugger, and the
> >CTRL-ALT-PAUSE works to suspend the machine, and CTRL-ALT-DEL works
> >to reboot...
> >
> >Does anyone know if this works?
> It works for me on 10.0.  Do you have debug.kdb.break_to_debugger=1
> and hw.syscons.kbd_debug=1 (if you're using syscons)?

Turns out I didn't... and you didn't need to...  emaste helped me
the other night discover this..  Apparently rwatson changed this and
the docs never got updated...  I saw BREAK_TO_DEBUGGER, bug it was
documented as being *serial* only, not syscons...

I've updated NOTES and added an entry for defaults/loader.conf, but
more docs need to be updated that BREAK_TO_DEBUGGER or the tunable
or sysctl needs to be set before if works..

  John-Mark Gurney                              Voice: +1 415 225 5579

     "All that I will do, has been done, All that I have, has not."
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to