What I did was:
Install subversion either from ports or via pkg install
Get the newest source code from FreeBSD by running the command svn checkout svn://svn.freebsd.org/base/head /usr/src (or whatever directory you might choose, I used /usr/src)
Then I ran make buildworld from the new /usr/src directory.
When make buildworld had completed, I cd-ed to /usr/src/release and ran sh ./generate-release.sh (this basically creates a chroot-ed environment, installs some tools, builds kernel and world and creates an ISO in /scratch/R/FreeBSD-something-disc1.iso). When the shell script generate-release.sh had completed, I ran the command mdconfig -a -t vnode -f /scratch/R/release/FreeBSD-something-disk1.iso -u 1 && mount -t cd9660 /dev/md1 /mnt. Then I created a new directory, /root/freebsd_generic_installer, copied the contents of /mnt/ to the new /root/freebsd_generic_installer directory and unmounted /mnt.


The following commands are taken from https://wiki.freebsd.org/UEFI#CD.2FDVD_Boot_under_UEFI:
> dd if=/dev/zero of=efiboot.img bs=4k count=100
> mdconfig -a -t vnode -f efiboot.img
> newfs_msdos -F 12 -m 0xf8 -L "FREEBSD_EFI" /dev/md0
> mount -t msdosfs /dev/md0 /mnt
> mkdir -p /mnt/efi/boot
> cp /boot/loader.efi /mnt/efi/boot/bootx64.efi
> umount /mnt
> mdconfig -d -u 0

Finally I created the new custom ISO by running the following command:
makefs -t cd9660 -o bootimage='i386;efiboot.img' -o no-emul-boot -o rockridge -o label=“FREEBSD_UEFI_INSTALL" -o publisher="test" discname.iso /root/freebsd_generic_installer/

For the above example to work, please make sure that /root/freebsd_generic_installer/etc/fstab has the following entry: /dev/iso9660/FREEBSD_UEFI_INSTALL / cd9660 ro 0 0, otherwise, the boot of the install DVD will stop with a mount error.

This is how I got the EFI FreeBSD installer to boot.

On 21/07/14 22:11, David King wrote:
Last week, I created a custom ISO from the latest -CURRENT sources which 
contained an EFI image that is bootable on my MacBook Pro.
Both installation and booting from this new FreeBSD 11 EFI system goes without 
any problems.
Somewhat off-topic, but can you detail how you did this? I've been at this 
unsuccessfully. Did you just do this 
<https://wiki.freebsd.org/UEFI#CD.2FDVD_Boot_under_UEFI>?

_______________________________________________
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to